You can only use this player if the Adobe Flash 10+ browser plug-in is installed.
Download Flash here.